Thứ Tư, 1 tháng 6, 2011

Lab0HSRP






Configure
Configure virtual IP
R1(config)# interface f0/0
R1(config-if)# standby 1 ip 192.168.123.254

R2(config)# interface f0/0
R2(config-if)# standby 1 ip 192.168.123.254
R3(config)# interface f0/0
R3(config-if)# standby 1 ip 192.168.123.254
Configure priority
R1(config)# interface f0/0
R1(config-if)# standby 1 priority 150

R2(config)# interface f0/0

R2(config-if)# standby 1 priority 120
Configure preempt
R1(config)# interface f0/0
R1(config-if)# standby 1 preempt
R2(config)# interface f0/0
R2(config-if)# standby 1 preempt
R3(config)# interface f0/0
R3(config-if)# standby 1 preempt
Configure authentication 
R1(config)# interface f0/0
R1(config-if)# standby 1 authentication MD5 key-string vnpro
R2(config)# interface f0/0
R2(config-if)# standby 1 authentication MD5 key-string vnpro
R3(config)# interface f0/0
R3(config-if)# standby 1 authentication MD5 key-string vnpro
When S0/0 of R1 down/down R2 will to become active (Configure track interface)
R1(config)# interface f0/0
R1(config-if)# standby 1 track s0/0 60
When S0/0 of R2 down/down R3 will to become active (Configure track interface)
R1(config)# interface f0/0
R1(config-if)# standby 1 track s0/0 40
When S0/0 of R1 loss IP address (interface up/up) R2 will to active instead R1 (Configure track object to monitoring IP on S0/0)
R1(config)# track 10 interface s0/0 ip routing
R1(config)# interface f0/0
R1(config-if)# standby 1 track 10 decrement 60
When S0/0 of R2 loss IP address (interface up/up) R3 will to active instead R2 (Configure track object to monitoring IP on S0/0)

R2(config)# track 10 interface s0/0 ip routing

R2(config)# interface f0/0
R2(config-if)# standby 1 track 10 decrement 40
When R1 lost of routing information 4.4.4.0/24 in the routing table, R2 becomes router active (track object)
R1(config)# track 11 ip route 4.4.4.0/24 reachability

R1(config)# interface f0/0
R1(config-if)# standby 1 track 11 decrement 60
When R2 lost of routing information 4.4.4.0/24 in the routing table, R3 becomes router active (track object)

R2(config)# track 11 ip route 4.4.4.0/24 reachability

R2(config)# interface f0/0
R2(config-if)# standby 1 track 11 decrement 40
Load balancing HSRP between R1, R2, R3 (Configure 3 group, one group is router active)
R1(config)# interface f0/0
R1(config-if)# standby 1 ip 192.168.123.254
R1(config-if)# standby 1 preempt
R1(config-if)# standby 1 priority 150


R2(config)# interface f0/0
R2(config-if)# standby 2 ip 192.168.123.253
R2(config-if)# standby 2 preempt
R2(config-if)# standby 2 priority 150


R3(config)# interface f0/0
R3(config-if)# standby 3 ip 192.168.123.252
R3(config-if)# standby 3 preempt
R3(config-if)# standby 3 priority 150
-------------The end---------------------

Configure ISP
 !


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.14.4 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 192.168.24.4 255.255.255.0
 clock rate 2000000
!
interface Serial0/2
 ip address 192.168.34.4 255.255.255.0
 clock rate 2000000
!
router ospf 100
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Configure R1

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
track 10 interface Serial0/0 ip routing
!
track 11 ip route 4.4.4.0 255.255.255.0 reachability
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.123.1 255.255.255.0
 speed 100
 full-duplex
 standby 1 ip 192.168.123.254
 standby 1 priority 150
 standby 1 preempt
 standby 1 track Serial0/0 60
 standby 1 track 10 decrement 60
 standby 1 track 11 decrement 60
!
interface Serial0/0
 ip address 192.168.14.1 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 100
 log-adjacency-changes
 network 192.168.14.0 0.0.0.255 area 0
 network 192.168.123.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Configure R2
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
track 10 interface Serial0/0 ip routing
!
track 11 ip route 4.4.4.0 255.255.255.0 reachability
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.123.2 255.255.255.0
 speed 100
 full-duplex
 standby 1 ip 192.168.123.254
 standby 1 priority 120
 standby 1 preempt
 standby 1 track Serial0/0 40
 standby 1 track 10 decrement 40
 standby 1 track 11 decrement 40
!
interface Serial0/0
 ip address 192.168.24.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 100
 log-adjacency-changes
 network 192.168.24.0 0.0.0.255 area 0
 network 192.168.123.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Configure R3

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.123.3 255.255.255.0
 speed 100
 full-duplex
 standby 1 ip 192.168.123.254
 standby 1 preempt
!
interface Serial0/0
 ip address 192.168.34.3 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 100
 log-adjacency-changes
 network 192.168.34.0 0.0.0.255 area 0
 network 192.168.123.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end


Configure SW
!





!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 duplex full
 speed 100
!
interface FastEthernet0/7
 duplex full
 speed 100
!
interface FastEthernet0/8
 duplex full
 speed 100
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
 no ip address
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end
-----------------------The end---------------

Không có nhận xét nào:

Đăng nhận xét