Thứ Năm, 12 tháng 5, 2011

DHCP-NAT-Rip






R1 Configuration
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.14.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface Ethernet1/0
 ip address 172.16.1.1 255.255.255.0
 ip helper-address 192.168.23.3
 full-duplex
!
interface Ethernet1/1
 ip address 192.168.13.1 255.255.255.0
 full-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.12.0
 network 192.168.13.0
 network 192.168.14.0
 no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end


R2 Configuration

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.23.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface Ethernet1/0
 ip address 172.16.2.2 255.255.255.0
 ip helper-address 192.168.23.3
 full-duplex
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.12.0
 network 192.168.23.0
 no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R3 Configuration

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
ip dhcp pool LanSW1
   network 172.16.1.0 255.255.255.0
   default-router 172.16.1.1
   dns-server 8.8.8.8
!
ip dhcp pool LanSW2
   network 172.16.2.0 255.255.255.0
   default-router 172.16.2.2
   dns-server 8.8.8.8
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.23.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.13.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.34.3 255.255.255.0
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
router rip
 version 2
 network 192.168.13.0
 network 192.168.23.0
 network 192.168.34.0
 no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R4 Configuration

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.14.4 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.34.4 255.255.255.0
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
router rip
 version 2
 network 192.168.14.0
 network 192.168.34.0
 no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

SW1 Configuration

version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW1
!
logging queue-limit 100
!
ip subnet-zero
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/1
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/2
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/3
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/4
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/5
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/6
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/7
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/8
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/9
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/10
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/11
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/12
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/13
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/14
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/15
 no ip address
 spanning-tree portfast
!
interface Vlan1
 ip address 172.16.1.254 255.255.255.0
!
ip http server
ip classless
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

SW2 Configuration

version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW2
!
logging queue-limit 100
!
ip subnet-zero
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/1
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/2
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/3
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/4
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/5
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/6
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/7
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/8
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/9
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/10
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/11
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/12
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/13
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/14
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/15
 no ip address
 spanning-tree portfast
!
interface Vlan1
 no ip address
 shutdown
!
ip http server
ip classless
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

-------------The end--------------

Không có nhận xét nào:

Đăng nhận xét