Thứ Sáu, 20 tháng 5, 2011

OSPF





Configure R1
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.2.1 255.255.255.0
!
interface Loopback3
 ip address 192.168.3.1 255.255.255.0
!
interface Loopback4
 ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.123.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.12.1 255.255.255.0
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 1
 network 192.168.2.0 0.0.0.255 area 1
 network 192.168.3.0 0.0.0.255 area 1
 network 192.168.4.0 0.0.0.255 area 1
 network 192.168.123.0 0.0.0.255 area 1
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Configure R2
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 192.168.16.2 255.255.255.0
!
interface Loopback2
 ip address 192.168.17.2 255.255.255.0
!
interface Loopback3
 ip address 192.168.18.2 255.255.255.0
!
interface Loopback4
 ip address 192.168.19.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.123.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.12.2 255.255.255.0
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 no dce-terminal-timing-enable
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 192.168.16.0 0.0.0.255 area 1
 network 192.168.17.0 0.0.0.255 area 1
 network 192.168.18.0 0.0.0.255 area 1
 network 192.168.19.0 0.0.0.255 area 1
 network 192.168.123.0 0.0.0.255 area 1
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Configure R3
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 192.168.24.3 255.255.255.0
!
interface Loopback2
 ip address 192.168.25.3 255.255.255.0
!
interface Loopback3
 ip address 192.168.26.3 255.255.255.0
!
interface Loopback4
 ip address 192.168.27.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.123.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 192.168.24.0 0.0.0.255 area 1
 network 192.168.25.0 0.0.0.255 area 1
 network 192.168.26.0 0.0.0.255 area 1
 network 192.168.27.0 0.0.0.255 area 1
 network 192.168.123.0 0.0.0.255 area 1
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Configure SW1
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW1
!
logging queue-limit 100
!
ip subnet-zero
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
 no ip address
!
interface FastEthernet0/1
 no ip address
!
interface FastEthernet0/2
 no ip address
!
interface FastEthernet0/3
 no ip address
!
interface FastEthernet0/4
 no ip address
 shutdown
!
interface FastEthernet0/5
 no ip address
 shutdown
!
interface FastEthernet0/6
 no ip address
 shutdown
!
interface FastEthernet0/7
 no ip address
 shutdown
!
interface FastEthernet0/8
 no ip address
 shutdown
!
interface FastEthernet0/9
 no ip address
 shutdown
!
interface FastEthernet0/10
 no ip address
 shutdown
!
interface FastEthernet0/11
 no ip address
 shutdown
!
interface FastEthernet0/12
 no ip address
 shutdown
!
interface FastEthernet0/13
 no ip address
 shutdown
!
interface FastEthernet0/14
 no ip address
 shutdown
!
interface FastEthernet0/15
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip http server
ip classless
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end
---------------The End----------------

Không có nhận xét nào:

Đăng nhận xét